Skip to content
Geek and I
Go back

Veeam 8 Error: Failed to open VDDK

Updated:
Mike Horwath1 min read

I needed a better solution for backing up my VMware virtual machines. Everyone I talked to had good things to say about Veeam. So I get a demo license and started to evaluate the product.

Installation was easy. Configuration was easy. Sparked a Windows 7 Professional 64-bit VM and tried to make a backup. Veeam choked with this error message:

Error: Failed to open VDDK disk [[netapp-2] win7-pro-64/win7-pro-64_1.vmdk]
( is read-only mode - [true] )
Failed to open VMDK.

I confirmed I was logged in as vsphere.local\Administrator:

Logon attempt with parameters [VC/ESX: [vmlab.local];Port: 443;Login: [vsphere.local\Administrator];

My GoogleFu failed me. I did find a troubleshooting tip to remove vCenter from Veeam and add an ESXi host directly. Did that and Veeam worked — so that helped narrow the problem down to vCenter.

Looking at the advanced logging:

[24.02.2015 20:03:32] < 1488> dsk| WARN|VDDK logon has failed.
Logon specification: [VC/ESX: [vmlab.local];Port: 443;Login: [[email protected]];
VMX Spec: [moref=vm-898];Snapshot mor: [snapshot-2079];Transports: [hotadd];Read Only: [true]].
VMDK path: [[netapp-2] win7-pro-64/win7-pro-64_1.vmdk]. Read only mode: [true].
[24.02.2015 20:03:32] < 1488> dsk| >> |VDDK error: 16064. The host is not licensed for this feature
[24.02.2015 20:03:32] < 1488> dsk| >> |Failed to open VMDK.

That led me to KB1225 which led me to this VMware article.

vCenter showed vsphere.local\Administrator as Administrator and the Disable Methods, Enable Methods, and Licenses were all checked.

More GoogleFu turned up this post (German, but Google translates it well).

Resolution: Remove the Basic/evaluation license from the vCenter Server License Manager and restart the VMware VirtualCenter Server service. For more information about the VDDK Diagnostic Tool, see the VDDK documentation.

Removed the unused Basic/eval license and now everything is working.



Related Posts

Previous Post
Fortigate Firmware 5.0 to 5.2.2 results in msg=\
Next Post
VMware Transparent Page Sharing change