According to the install documentation, VMware vSphere 4 ESX and ESXi 4.1 update 1 are supported.
Install or upgrade to vCloud Director 1.5 will fail with the following error when trying to add the provider vDC:
Could not retrieve state for sequence: seq_os
This is easily fixed by editing the database table os_id and inserting the relevant information.
For ESX:
os_type=vmnix-x86name=VMware ESXversion=4.1.0update_level=1is_supported=1
And for ESXi:
os_type=vmnix-x86name=VMware ESXiversion=4.1.0update_level=1is_supported=1
then restart the setup of your provider vDC and you should be all set.